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MESHGEO / EXPORTGEO-CAD 

With MeshGeo and ExportGeo-CAD, structures in GeoDict formats can be converted 
to a surface mesh. Since GeoDict 2021, it is also possible to create meshes directly 

from grey value images, index images and volume fields. These options add many 
new possibilities: For example, it is now possible to import µCT images and convert 

them to smooth meshes with sub-voxel precision. Furthermore, creating triangulation 
from GeoDict index images allows the transfer of the object information from 
GeoDict’s structure generators to external software. 

◼ MeshGeo keeps the mesh in memory after creation and allows subsequent 
smoothing and coarsening operations. For this, MeshGeo contains the additional 

options, Smooth Mesh and Coarsen Mesh. Afterwards, the mesh can be saved 
in different file formats with Save Mesh.  

◼ ExportGeo-CAD saves the created mesh directly to the hard disk. Therefore, it is 
not possible to edit the mesh after creation. 

Since both modules work in a similar way, only MeshGeo is explained in this handbook 

where it matches the functionality of ExportGeo-CAD. 

To access MeshGeo, select Model → MeshGeo in the menu bar: 
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To access ExportGeo-CAD, select Export → ExportGeo-CAD in the menu bar: 

 

In the MeshGeo or ExportGeo-CAD section, to the left of the Visualization area, a 
pull-down menu displays the choices for the meshing options. The options available 

for Create Mesh are the same for both modules. 

Additionally, MeshGeo contains options to further edit and save the mesh. For 

ExportGeo-CAD, the mesh is directly saved after the creation. The available options 
to save the mesh are the same for both modules and explained together in pages 

10 ff. 
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VISUALIZE SURFACE MESHES IN GEODICT 

When a mesh is currently loaded in GeoDict and displayed in the Visualization area, 
the Triangles tab becomes available in the Visualization panel, above the 
Visualization area.  

In this tab, various settings for the visualization of the mesh can be selected. These 
settings are explained in detail in the ImportGeo-CAD handbook of this User Guide. 

 

https://geodict.com/fileadmin/script/UserGuide.php?lang=en&chapter=ImportGeoCAD&release=2023
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CREATE MESH 

Select Create Mesh in MeshGeo or Export Voxel Mesh in ExportGeo-CAD and 
specify the type of mesh from the pull-down menu. Meshes of a structure in GeoDict 
can be created based on the voxel information (Voxel Mesh). This voxel information 

can be a structure, a grey value image, an index image, or a volume field. 

Alternatively, a mesh can be created based on the analytic objects in the structure 

(Object Mesh). 

Additionally, it is also possible to mesh particles (Particles Mesh) and their 
trajectories (Trajectories Mesh) from results obtained with AddiDict or FilterDict or 

streamlines (Streamlines Mesh) from results obtained with FlowDict, AddiDict or 
FilterDict.  

The parameters for the selected mesh type can then be defined by clicking the Edit… 
button.  

 

When all settings have been chosen, click Run at the bottom of the MeshGeo or 
Export at the bottom of the ExportGeo-CAD section to create the mesh. 
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VOXEL MESH 

For voxel meshes in MeshGeo, two tabs are available in the Create Voxel Mesh 
Options dialog (Voxel Mesh Options and Coarsen).  

A third tab, Output Options is only 
available in ExportGeo-CAD since the 

mesh is directly saved after creation.  

It contains the same options as Save 
Mesh in MeshGeo. See page 10 for 

further information. 

 

 

 

 

 

 

 

 

 

 

VOXEL MESH OPTIONS 

The Voxel Mesh option allows to create triangulations from the available voxel 
information. The kind of voxel information is selected with the Volume pull-down 
menu: It can be a GeoDict structure (this is the default), a grey value image, an index 

image, or a volume field. Additionally, the Mode defines how the volume is meshed. 
The choices for Volume and Mode change the other available options. 

VOLUME 

Different types of Volume of structure information can be meshed in Create Mesh 

→ Voxel Mesh. The available options are explained below. 

Current Structure 

With this option, the currently loaded voxel structure is converted to a mesh. For 
Current Structure, all four Modes are available: Voxel Surface, Rounded, Smooth 

and Multi Material. 

Current Grey-Value Image 

Instead of first converting a grey-value image to a voxel structure (with ImportGeo -
Vol), it is now directly possible to directly mesh the Current Grey-Value Image. In 

this case, the Mode is fixed to Rounded. Based on the given Threshold, an iso 
surface is created that splits the structure in two phases. The normal of the iso surface 
point into the pore space. If Automatic Threshold is selected, the OTSU algorithm 

is used to determine the threshold. 
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With this option, all information from the grey value image can be used. The created 

mesh is smoother than a mesh created from a segmented voxel structure, and the 
additional grey value information allows to obtain sub-voxel precision. 

 

 

Index Image 

By choosing an Index Image as Volume, it is possible to use the object indexes to 
create Multi Material triangulations. Analogously, the object indexes from GrainFind 
or FiberFind results can be used in the same way. Each object with a given index is 

converted to its own mesh, and the meshes for different objects do not overlap. The 
Mode is fixed to Multi Material, since this is the option that keeps the object 

information and preserves the partition of unity. 

 

In the figure below, to the left an index image from a GrainFind result is shown. To 
the right, you can see the mesh calculated from that index image. 
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Volume Field 

With the Volume Field option, triangulations can 
be created from arbitrary GeoDict results. In the 

example below, a flow field from a FlowDict 
simulation is converted to a mesh. The Volume 
Field option works analogously to the Current 

Grey-Value Image option: It creates an iso-
surface mesh based on the given Threshold. 

In the figure below, observe from left to right: A 
flow field calculated with FlowDict, the flow field 
with a threshold (i.e. only fast velocities are 

shown), and a mesh computed with the same 
threshold. 

 

MODE 

Four Modes can be used to export voxel data: Voxel Surface, Rounded, Smooth, 
or Multi Material. Multi Material is the default. Which options are available depends 

on the selected Volume: For example, if the Current Grey-Value Image is selected, 
only Rounded is available. 
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Voxel Surface exports the exact surface of the voxel structure with its characteristic 

rectangular edges. This option is available in GeoDict to ensure compatibility with 
older releases. In general, it is not recommended to use Voxel Surface since the 

Multi-Material mode leads to better results. 

The Smooth algorithm is an improved version of the marching cubes algorithm which 

produces a mesh with a better triangle quality. The mesh is smoothed during creation. 
This surface is not constrained to the domain and the surfaces of multiple materials 
may intersect. Smooth is the most suitable export mode for visualization purposes.  

Rounded works analogously to the Smooth export, but it focuses on triangle quality 
instead of smoothness. The exported surface is constrained to the domain and the 

surfaces of multiple materials may intersect. This export mode is most suitable for 
numerical simulations with only one material phase (e.g. flow simulations in the pore 
space). 

 

 

Structure in GeoDict 

https://en.wikipedia.org/wiki/Marching_cubes
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With the Multi Material option, the meshes for the different materials do not overlap. 

They have perfect contact at the points where different materials touch. When all 
materials are exported, a partition of unity is created. This means that each point in 

the domain is enclosed in exactly one surface. This property is preserved with further 
processing steps (e.g. Smooth Mesh or Coarsen Mesh). 

Multi material meshes are constrained to the domain. This export mode is suitable 
to mesh multi-material microstructures for numerical simulations.  

MATERIAL TO MESH 

Select the material IDs to be meshed with the options under Material to Analyze. 

With the first three options, either All Materials, the Pore Space or All Solid 
Materials are meshed. 

All Solid Materials is the default, since this is the best choice for most use cases. 

 

With Chosen Material, all material IDs for the given material are selected.  

 

With Chosen Material IDs, individual material IDs can be selected. 
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PERIODICITY 

When Periodicity is selected, a periodic mesh is created in the chosen direction. This 

option should only be used if the original structure is periodic. Otherwise, symmetric 
boundary conditions are applied. This option is only available for the Multi Material 
mode. 

CLOSE PERIODIC WALLS 

When Periodicity is selected for a direction, the mesh walls are by default open at 
the boundaries. With Close Periodic Cell Walls, these periodic walls are closed. This 
option is only available for the Multi Material mode. 

AVOID REPEATING EDGES 

Where different materials are in contact, their voxel surfaces share the same edges. 
This is not allowed in a mesh in the STL format. With Avoid Repeating Edges, these 
edges are shifted slightly inwards the material. Then, each material has different 

edges. This option is only available for Voxel Surface mode. 

For the Multi Material option, such an option is not necessary since there, the 

different materials are saved to different meshes. 

ADD TO CURRENT MESH 

Add to current mesh is only available for MeshGeo. When this option is selected and 
a mesh is already in memory, the new mesh is added to that mesh. Multiple meshes 

can then be edited together and be saved to a single file.  

See Smooth Mesh in page 22 and Coarsen Mesh 

 in page 25 . 

COARSEN 

Coarsening can either be applied during mesh creation or afterwards. The settings 

are the same, but the results may differ – especially if the Adaptive mode is used. 
For further information, see page 25. 
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OBJECT MESH 

To export the objects in the structure into a mesh, select Analytic Mesh from the 
pull-down menu. Objects in GeoDict can overlap. With Analytic Mesh, each object is 

meshed separately, therefore the meshes for the different objects can overlap, too. 
If it is important that these meshes do not overlap, use the Multi Material mode 

(see page 9) instead. 

Analytic Mesh does not work for combined objects or intersected objects. Check out 
the GadGeo handbook of this User Guide for more information about these object 

types. 

 

OBJECT PROCESSING 

If Object Processing is set to Unprocessed, the complete objects are meshed, 

even if they lie not completely in the domain. With Cut to Domain, only the part of 
the object which is inside the domain is meshed. 

 

 

 

https://geodict.com/fileadmin/script/UserGuide.php?lang=en&chapter=GadGeo&release=2023
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MATERIAL TO ANALYZE 

The choices for Material to Analyze are explained on page 9. For Analytic Mesh, 

not all material IDs in the structure can be used to create a mesh. For example, the 
pore space is not an object in GeoDict and therefore no analytic mesh can be created 
from it. Furthermore, the overlap between objects is not an analytic object itself and 

can therefore not be meshed. To create a mesh of e.g. the pore space or the overlap 
regions, use the Voxel Mesh option instead. 

EXPORT OBJECTS IN RANGE 

Each object in a structure has an object ID. If only some of these objects should be 

meshed, a range of objects can be selected with Export Object in Range. 
Alternatively, the structure can be edited so that it only contains the desired objects 

(for example, with GadGeo-Edit GAD Objects). See the GadGeo handbook of this 
User Guide for further information). 

 

To find the object number of a given object, hover the mouse over the object in 2D 
or 3D view and check out the ToolTip. 

 

https://geodict.com/fileadmin/script/UserGuide.php?lang=en&chapter=GadGeo&release=2023
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QUALITY MODE 

Objects in GeoDict can be meshed in different resolutions. The Quality Mode defines 
if this resolution is fixed or if it depends on the object size. 

 

With Quality Mode set to Fixed, the Fiber Quality and Ellipsoid Quality are 
defined globally for the structure. When choosing Size Dependent, minimal and 

maximal values must be defined. This option is recommended if the size of the objects 
in the structure varies by a large amount. 

The quality can only be selected for fibers and ellipsoids. For the other object types 
available in GeoDict, meshing is either trivial so that only one reasonable mesh exists 

(Box, Triangle, Planar Polyhedron, Convex Polyhedron type objects) or not 
possible in GeoDict (Combined Object and Intersected Object, where no analytical 
mesh definition exists). 

Fiber Quality 

Fiber Quality controls the resolution for fibers. The entered value determines the 

number of nodes in which the profile shape is resolved. 

◼ For fibers with circular and ellipsoidal cross-section, the Fiber Quality 

corresponds to the number of nodes with which the cross-section of the fiber is 
discretized. This does also hold for fibers of hollow and cellulose types. 

◼ For rectangular and angular fibers, the Fiber Quality has no effect on the 

discretization of the cross-section. This is because these fiber types are already 
perfectly resolved with one node per side. 

◼ For Rosetta fibers, the Fiber Quality corresponds to the number of nodes per 
leaf. 

 

Fiber Quality for circular fibers 

4 8 16 32 
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Ellipsoid Quality 

The Ellipsoid Quality determines the resolution of the mesh for spheres and 

ellipsoids. In contrast to the Fiber Quality, the Ellipsoid Quality is an exponential 
measure for the resolution. For the value 0, the shape of the sphere or ellipsoid is 

meshed as an octagon. With each increase of the parameter, each of the triangles is 
refined into four new triangles. Therefore, a meshed sphere with 
Ellipsoid Quality =  0 contains 8 triangles and for Ellipsoid Quality = 1, it contains 

32 = 8 x 4 triangles. For Ellipsoid Quality = 2, it contains already 256 = 8 x 42 and 
so on.  

 

TARGET ASPECT RATIO 

The Target Aspect Ratio specifies the desired aspect ratio of the triangles in the 
surface triangulation. Lower values will create more triangles of higher quality. 

ADD TO CURRENT MESH 

See Add to current mesh, in page 10. 

  

Fiber Quality for hollow fibers 

4 8 16 32 

Fiber Quality for Rosetta fibers 

4 8 16 

Ellipsoid Quality 

0 1 2 3 4 
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PARTICLES MESH 

Particle positions and trajectories can be obtained from FilterDict and AddiDict 
simulations. MeshGeo can create a mesh from the currently loaded particles in 

GeoDict. The mesh is always created at the particle positions currently shown in 
GeoDict. Particles and trajectories can be loaded e.g. from a FilterDict or AddiDict 

result file.  

To do so, select File → Open Results (*.gdr)… from the menu bar or click the  

icon in the toolbar. Select a GeoDict results file to open it in the Result Viewer. Click 

Load Structure to load the structure for which the results were computed. Under the 
Result Visualization tab, click Load Particles. 

Start MeshGeo, select Create Mesh and Particles Mesh in the MeshGeo section and 
click the Options’ Edit… button to set the parameters. When all settings are chosen, 

click the Run button at the bottom of the MeshGeo section to create the mesh. 

PARTICLE QUALITY 

The Particle Quality defines the number of triangles in the mesh for each particle. 

Particles in GeoDict are spherical, and the definition of the Particle Quality is the same 
as the Ellipsoid Quality (see page 14).  

 

 

Observe the effect of the Particle Quality here: 

 

 

 

 

 

 

  



MeshGeo and ExportGeo-CAD: convert structures to surface triangulations 

16 GeoDict 2023 User Guide 

TRAJECTORIES MESH 

As mentioned above, particle positions and trajectories can be obtained from FilterDict 
and AddiDict simulations. MeshGeo can create a mesh from the currently shown 

trajectories in GeoDict. Particles and trajectories can be loaded e.g. from a FilterDict 
or AddiDict result file. 

To do so, select File → Open Results (*.gdr)… from the menu bar or click the  

icon in the toolbar. Select a GeoDict results file to open it in the Result Viewer. Click 
Load Structure to load the structure for which the results were computed.  

Under the Particle Visualization (FilterDict) or Data Visualization (AddiDict) tab, 

make sure that Trajectories is checked and click the Load Particles button. 

Start MeshGeo, select Create Mesh and Trajectories Mesh in the MeshGeo section 

and click the Edit… button to set the parameters. When all settings are chosen, click 
the Run button at the bottom of the MeshGeo section to create the mesh. 

 

DIAMETER 

The Diameter option defines the diameter of the meshed trajectories. The available 

options are Particle Diameter and Fixed Diameter. When Particle Diameter is 
chosen, the diameter of the corresponding particles is used. With Fixed Diameter, 

the given Trajectory Diameter is used. 

 

TRAJECTORY QUALITY 

The Trajectory Quality sets the quality of the trajectory mesh. It is defined 

analogously to the Fiber Quality for analytic meshes. See page 13 for further 
information. 

ADD TO CURRENT MESH 

See Add to current mesh in page 10. 
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Trajectories Meshed trajectories 
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STREAMLINES MESH 

GeoDict can visualize streamlines in flow simulation results (e.g. from FlowDict, 
FilterDict, AddiDict, SatuDict, and AcoustoDict). MeshGeo can create a mesh from the 

currently shown streamlines in GeoDict.  

Start MeshGeo, select Create Mesh and Streamlines Mesh in the MeshGeo section 

and click the Edit… button to set the parameters. When all settings are made, click 
the Run button at the bottom of the MeshGeo section to create the mesh. 

 

STREAMLINE DIAMETER 

The Streamline Diameter option defines the diameter of the meshed streamlines. 

STREAMLINE QUALITY 

The Streamline Quality sets the quality of the streamlines mesh. It is defined 
analogously to the Fiber Quality for round fibers (In Create Mesh → Analytic Mesh). 

See page 13 for further information. 

ADD TO CURRENT MESH 

See Add to current mesh in page 10. 

 
Streamlines Meshed streamlines 
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SAVE MESH 

Save Mesh writes the currently loaded mesh to a file. When a surface triangulation 
is loaded, select Save Mesh, and then click Save. 

A dialog opens which allows to select the settings for the saved file. This dialog 

contains the same options as the Output Options tab in ExportGeo-CAD (see 
screenshots below). 

Save Mesh can also be reached via File → Save Triangulation as….  

 

Save Mesh options in MeshGeo 

 

Output Options tab in ExportGeo-CAD 

 

RESULT FILE NAME 

When saving a mesh, a result file is saved in the project folder and contains 
information about the selected parameters. Select the Result File Name (*.gdr) in 

the text box. The mesh files are also saved in the project folder.  

FILE FORMAT 

Select the File Format for the saved mesh.  

The Stereolithography (*.stl), VRML (*.wrl) and Wavefront OBJ (*.obj) formats can 
be exported natively by GeoDict . Parasolid (*.x_t), Iges (*.igs), Step (*.stp) and Acis 

(*.sat) require the purchase and installation of the additional software CADLook.  

If necessary, contact Math2Market for further information. 

https://en.wikipedia.org/wiki/STL_%28file_format%29
https://en.wikipedia.org/wiki/VRML
https://en.wikipedia.org/wiki/Wavefront_.obj_file
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ADDITIONAL OPTIONS FOR THE *.STL FORMAT 

If the STL format is chosen, two additional options appear: Write STL in ASCII 

format and Write Multiple Files. 

Write STL in ASCII-Format 

When Write STL in ASCII-Format is selected, the file is saved as human readable 
ASCII file. Otherwise, the STL file is saved in binary format. The binary files are 

smaller and much faster to read and write. Therefore, the ASCII format should only 
be used if necessary. 

 

Write Multiple Files 

When the STL format is chosen and multiple meshes are currently loaded, these 

meshes can be saved to different files if necessary. This option is enabled with Write 
Multiple Files. For the other file formats, multiple meshes are always saved to one 
file. 

LENGTH UNIT 

The unit in which the data is saved to the file can be selected with Length Unit. 
GeoDict can handle all these available units, but most external software cannot. 
Therefore, the unit should be chosen depending on the software with which the mesh 

is further processed. 

 

In the STL format, the information about the used unit is not contained in the file. 

The files for different units differ only in the order of magnitude of the data. 
Therefore, the unit should be chosen carefully based on your needs. 
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SMOOTH MESH 

Meshes from voxel structures often have a significant surface roughness which can 
be reduced by applying smoothing filters.  

In MeshGeo, three smoothing filters are selectable from the pull-down menu to 

improve the mesh quality: Taubin, Laplacian, or Constraint Laplacian. Choose a 
filter and click Smooth to apply the selected filter to the current mesh. 

 

Smoothing is best shown on a structure with an irregular surface. The example 
structure created here is a grain with surface roughness. The original mesh before 

smoothing is created with Create Mesh → Voxel Mesh and the Multi Material mode 

(see page 9). 

To observe the difference between the different mesh types, it is recommended to set 
the View Mode to Faces and Wireframe (Triangles tab → View Mode → Faces 

and Wireframe, in the Visualization panel above the Visualization area). 

 

Voxel structure 
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The Taubin filter is the default smoothing 

filter in GeoDict. This filter iteratively 
combines different Laplacian filters to provide 

a better volume preservation. The runtime for 
Taubin is longer than for Laplacian. In the 

screenshot on the right, observe that the 
mesh is rougher than the result after 
Laplacian filtering, while its volume is closer 

to the volume of the original voxel structure. 

For further information about the Taubin filter, 

see [Reference (1)]. 

 

 

The Laplacian filter is a simple and fast 

option for mesh smoothing. However, this 
filter causes mesh shrinking for most 

geometries. For further information, see 
Wikipedia: Laplacian Smoothing. 

 

 

The Constraint Laplacian filter is a 

derivation of the Laplacian approach, but it 
ensures that points from the triangulation stay 
in the voxel they originated from. This results 

in an even better preservation of the volume, 
but it can also lead to artefacts in the mesh 

(Observe the small peaks on the surface in the 
example on the right). 

  

 

https://en.wikipedia.org/wiki/Laplacian_smoothing
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References 
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https://ieeexplore.ieee.org/document/466848
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COARSEN MESH 

Coarsen Mesh in MeshGeo reduces the number of triangles in the currently loaded 
surface mesh.  

When a surface triangulation is loaded, select Coarsen Mesh and click Edit to open 

the Coarsen dialog. 

Generally, it is not supported to use Coarsening on the voxel surface mesh (Create 

Mesh → Voxel Mesh → Voxel Surface). Use the other voxel mesh modes or 

previous mesh smoothing instead. 

 

COARSENING MODE 

MeshGeo provides three modes to coarsen triangulations, based on the stopping 
criteria for the coarsening algorithm: by Percentage Reduction of Triangles, by 
Edge Length, and by Target Number of Triangles.  

The coarsening algorithm reduces the number of triangles in the currently loaded 
mesh by combining short edges to longer edges.  

 

PERCENTAGE REDUCTION OF TRIANGLES 

Percentage Reduction of Triangles removes at least the given percentage of 
triangles. The reduction of the triangle number is done with an iterative algorithm. 

The algorithm stops, if either the requested reduction is achieved, or no further 
reduction is possible.  

To choose the value, use the option Triangle reduction /(%). 
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In the screenshots below, the effect of reducing the number of triangles by 25 % and 
75 % is shown. 

 

 

 

 

 

EDGE LENGTH 

With the Edge Length mode, the number of triangles in the current mesh is reduced 

depending on two inputs: Minimal Edge Length and Maximal Edge Length. 

The input given for Minimal Edge Length sets the length of edges to be removed. 
All edges shorter than this value are removed in the algorithm.  

The input given for Maximal Edge Length sets the upper bound for the created 
edges which should not be exceeded. 

 

The coarsening algorithm takes all edges smaller than the minimal edge length and 
combines them until no edge is smaller than the minimal edge length. The algorithm 
tries not to exceed the maximal edge length in the process.  

Nevertheless, it is not always possible to satisfy the given maximal edge length. 

Original mesh 
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TARGET NUMBER OF TRIANGLES 

Target Number of Triangle reduces the number of triangles in the current mesh 

until the Target Number of Triangles is reached.  

ADAPTIVE 

Adaptive is only available for the modes Percentage Reduction of Triangles and 

Target Number of Triangles. With Adaptive, the coarsening algorithm minimizes 
the deviation of the coarsened surface from the original surface. The Adaptive 

algorithm generates a mesh with a non-uniform triangle size and can lead to triangles 
with bad aspect ratios. 

When the Adaptive mode is disabled, the coarsening algorithm works based on the 

edge lengths in the mesh. 
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REPAIR MESH 

Repair Mesh provides options to repair meshes. The parameters for repairing the 
mesh can be defined by clicking the Edit… button.  

Repair Mesh is only available in MeshGeo, since it works on the mesh currently loaded 

in GeoDict. With ExportGeo-CAD, the meshes are saved directly and not loaded in the 
GeoDict user interface. 

When a surface triangulation is loaded, select Repair Mesh and click Edit… to open 
the Repair Mesh dialog. 

 

When all settings have been chosen, click Repair at the bottom of the MeshGeo 
section to create the mesh. 

DO EDGE FLIP OPTIMIZATION 

With Do Edge Flip Optimization, folded edges in the mesh are analyzed and 
repaired by edge flipping. Folded edges are edges which meet in an angle close to 0°, 

which can cause problems when further working with the mesh.  

Edge flipping refers to switching the end points of an edge in two adjacent triangles, 

which can help to avoid small angles. A simple example is shown in the screenshot 
below, where one of the triangles on the left has a very small angle. By flipping the 
edges, this problem is resolved. 
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REMOVE DUPLICATED TRIANGLES 

The duplicated triangles are checked and removed with Remove Duplicate 

Triangles. Two possibilities are possible for the removing. One is Reduce to One 
Triangle, which leaves one instance of each set of duplicate triangles. The other one 

is Remove All, which removes all instances of each set of duplicate triangles.  

STITCH ADJACENT MESHES 

With Stitch adjacent meshes, the meshes with overlapping boundary edges are 

merged. If Same material IDs only is checked, the merge is done only when the 
material IDs of the overlapping meshes are the same. Otherwise, the meshes with 

different material IDs are merged, too. 

MANUAL ACCURACY FOR VERTICES 

The option of Manual Accuracy for Vertices is valid only when Remove 

Duplicate Triangles is used to define a threshold to compensate for numerical 
inaccuracies in vertex coordinates. The mesh vertices with at most the distance 

given for Epsilon / (µm) is treated as equal.   
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REMESH MESH 

The loaded mesh can be re-meshed with given edge length of triangles. click Edit to 
open the Remesh Mesh dialog. 

 

NUMBER OF ITERATIONS 

The Number of Iterations option defines the number of iterative meshing steps. In 
each iteration, the mesh is proceeded such that edge lengths are converging into the 

given target value and vertices are evenly distributed on the surface. 

TARGE EDGE LENGTH 

The remeshing aims to optimize the mesh such that the edge length converges to the 

Target edge length. 

PRESERVE DOMAIN BOUNDARIES 

If Preserve domain boundaries is checked, the mesh vertices that are located on 

the domain’s boundary will remain on the boundary after remeshing. 

To illustrate the features, an example of a ball with 20 µm diameter with the voxel 

length 1 µm is used for meshing (Create Mesh), remeshing (Remesh Mesh), and 
smoothing (Smooth Mesh) to show the different meshes created.  
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First, a voxel mesh is created with the settings shown 
in the dialogs above, without any Coarsen.  

 

Remesh Mesh is executed with 200 as the Number 
of iterations and 2 µm as the Target edge length. 

 

 

The mesh is then smoothed with the Taubin filter. 
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VOXELIZE MESH 

With Voxelize Mesh, a voxel structure is generated based on the currently loaded 

meshes. Voxelize Mesh provides the same functionality as ImportGeo-CAD, the 
only significant difference is that ImportGeo-CAD works on the meshes during their 

import, while Voxelize Mesh works on the meshes which are already in memory. 

Voxelize Mesh is only available in MeshGeo, since it works on the mesh currently 
loaded in GeoDict. With ExportGeo-CAD, the meshes are saved directly and not 

loaded in the GeoDict user interface.  

When a surface triangulation is loaded, select Voxelize Mesh and click Edit… to 

open the Voxelize Mesh dialog. When all settings have been chosen, click Voxelize 
at the bottom of the MeshGeo section to create the mesh. 

 

The settings in the Voxelize Mesh dialog are analogous to the ImportGeo-CAD 
dialog. Please refer to the ImportGeo-CAD handbook for further explanation of the 

settings. The settings which correspond to the domain size are not available here 
since these are taken from the currently loaded structure. 

https://geodict.com/fileadmin/script/UserGuide.php?lang=en&chapter=ImportGeoCAD&release=2023
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SPLIT MESHES INTO CONNECTED COMPONENTS 

With Split Meshes into Connected Components, an individual mesh handle is 

created for each connected component of the loaded surface triangulation.  

 

For example, a surface mesh loaded from a single .stl file as shown below for two 

spheres. There is a single mesh handle for all the objects.  

Open the settings dialog for Reassign Mesh Material ID (see below in page 36) 

and observe that only one mesh is shown. 

 

Now come back to Split Meshes into Connected Components. Since the 
command detects the connected components automatically and separates them into 

individual mesh, no settings are necessary. Here just click Split to make it work. 

When opening the dialog of Reassign Mesh Material ID again, two mesh handles 

now appear for the two spheres.  

Now, separately, the two meshes can be saved (Save Mesh), deleted (Delete 
Mesh), or assigned to different Material IDs (Reassign Mesh Material ID).  
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DELETE MESH 

The selected meshes can be deleted with Delete Mesh.  

 

Click Edit… to open the Delete Selected Mesh dialog, the meshes currently 

loaded in memory are shown in the Mesh column.  

 

Click the checkboxes under Delete Mesh column for the meshes needed to be 

deleted, then click OK to go back to the MeshGeo section.  

Click Delete to remove the selected meshes. 
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REASSIGN MESH MATERIAL ID 

Each mesh can be assigned to a different material ID with Reassign Mesh Material 

ID.  

 

For the example of two spheres shown in Split Meshes into Connected 
Components,(page 33) click Edit… to open the dialog. 

Choose Material 02 for the small sphere 2, and click OK. Click Reassign in MeshGeo 

section. The two spheres now have different material IDs. 
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SHIFT MESH 

Meshes can be shifted with a given distance with Shift Mesh.  

 

Select Shift Mesh and click Edit… to open the Shift Mesh dialog. Choose the mesh 
to be shifted on the right box and give the values for Shift X, Shift Y, and Shift Z 

for the shift distance in X, Y, and Z direction, respectively.  Click OK to close the 
dialog and go back to MeshGeo section. Click Shift to move the green sphere in the 
negative Z-direction  by a distance of 40µm.  
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SCALE MESH 

The mesh can be scaled with Scale Mesh. 

 

For the two sphere example from the previous page, the comparison of the meshes 
before and after a scaling of 2 for x, y, and z are shown below. 

Select Scale Mesh and click Edit to open 
the dialog of Scale Mesh.  

Choose the mesh to be shifted on the right 
box and give the scaling factors for x, y, 

and z coordinate in Scale X, Scale Y, and 
Scale Z.  
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If the mesh of the green particle is saved, it can be observed that the coordinates of 

x, y, and z after scaling are two times of the original values.  

Here, below, the first image shows the first lines of values in STL before scaling. The 

second image shows the values after scaling. 

 

 

 



MeshGeo and ExportGeo-CAD: convert structures to surface triangulations 

40 GeoDict 2023 User Guide 

ROTATE MESH 

If a mesh needs to be rotated, select Rotate Mesh from the pull-down menu and 

click Edit… to open the Rotate Mesh dialog. 

 

Enter the Euler Angles Phi, Theta, Psi by which the selected should rotate. More 

details about Euler Angles can be found in GadGeo handbook. 

The rotation can be around either the domain center or domain origin. 

 

 

https://en.wikipedia.org/wiki/Euler_angles
https://geodict.com/fileadmin/script/UserGuide.php?lang=en&chapter=GadGeo&release=2023
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Image (a) shows the original mesh.  

Image (b) shows the mesh after the rotation of Phi with 90° around the domain 
origin.  

Image (c) shows the rotation of Phi with 90° around the domain center.  

 

 

(a) 

(b) 

(c) 
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